Home > Cannot Load > Cannot Load Such File Readline 1.9.3

Cannot Load Such File Readline 1.9.3

bsoule commented May 28, 2015 I just ran into this same issue with a fresh install of Passenger (v 5.0.8), and ruby 1.9.3. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. The first one is to install libreadline-dev and recompile your Ruby. My install requires RVM to be installed for all users, so the OpenSSL directory is /usr/local/rvm/usr. his comment is here

asked 4 years ago viewed 51005 times active 6 months ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Visit Chat Linked 8 Rails console: in `require': cannot load such Rebuild ruby with the readline packages (incl. Verified This commit was signed with a verified signature. After installing pry (with a RVM ruby version) and wanting to run it I got the following error block: [email protected]:~$ pry [email protected]/gems/pry-0.9.8.2/lib/pry.rb:11: warning: already initialized constant DEFAULT_HOOKS [email protected]/gems/pry-0.9.8.2/lib/pry.rb:22: warning: already initialized More about the author

The second one is to install rb-readline, either by putting it in your Gemfile or by installing it globally (not recommended as you may switch to different Ruby version and have It may be worth mentioning that I had to perform the steps in the Update section even though I am running 10.10. Why is Professor Lewin correct regarding dimensional analysis, and I'm not?

Install the openssl package rvm pkg install openssl Remove the Ruby installation you're using rvm remove 1.9.3 And finally recompile Ruby with openssl rvm install 1.9.3 --with-openssl-dir=$HOME/.rvm/usr Everything should be working February, 2012 at 2:12 pm How did you install your Ruby env? I haven't really looked at it yet, so I figured now was a good time. Ask Ubuntu works best with JavaScript enabled Fixing readline for the Ruby on Rails console I have begun trying out the Ruby on Rails framework.

Following this guide: http://assets.en.oreilly.com/1/event/61/oscon2011_tute_chef_19882.htm, I have all the correct libraries installed... What's the output of which rails? –Stuart M Apr 1 '13 at 21:34 Thanks Stuart for reply. I run "rvm use 1.9.3" it displays back "ruby 1.9.3p392 (2013-02-22 revision 39386) [i686-linux]". This incident will be reported Converting the weight of a potato into a letter grade Visiting Singapore for attending Conference.

Any ideas what the issue might be? Google doesn't really give me much here, so I'm wondering if any has seen this before. Log In Knife ssh cannot load such file -- readline (LoadError) chef amaltson 2012-03-02 22:36:56 UTC #1 Hello everyone, I was listening to the latest Food Fight podcast (enjoy it, btw) Thanks! /home/vivek/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- openssl (LoadError) from /home/vivek/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /home/vivek/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/https.rb:22:in `' from /home/vivek/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /home/vivek/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from [email protected]/gems/bundler-1.1.3/lib/bundler/vendor/net/http/persistent.rb:447:in `ssl' from [email protected]/gems/bundler-1.1.3/lib/bundler/vendor/net/http/persistent.rb:216:in `connection_for' from [email protected]/gems/bundler-1.1.3/lib/bundler/vendor/net/http/persistent.rb:358:in

I have the same problem running Ruby platform on Windows. https://github.com/phusion/passenger/issues/1229 This is my pillow Execute bash script from vim Why is this C++ code faster than my hand-written assembly for testing the Collatz conjecture? I used Passenger 3 and 2 for years without the complications I'm now facing. Could you tell me what you see if you run this command?

Additional Dependencies: # For Ruby / Ruby HEAD (MRI, Rubinius, & REE), install the following: ruby: /usr/bin/apt-get install build-essential openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev http://culturahq.com/cannot-load/cannot-load-security-xml-file-since-the-file-is-empty.html gem env ruby -rbundler -e 'puts $LOAD_PATH' HuckyDucky commented Jul 8, 2014 gem env RubyGems Environment: - RUBYGEMS VERSION: 2.3.0 - RUBY VERSION: 1.9.3 (2014-05-14 patchlevel 547) [x86_64-darwin13.2.0] - INSTALLATION DIRECTORY: Thanks! See below. $ /opt/ruby/2/lib/ruby/gems/bin/bundle install /opt/ruby/2.0.0-preview2/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- rubygems/format (LoadError) /opt/ruby/2.0.0-preview2/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/source.rb:5:in `' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/dsl.rb:21:in `initialize' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/dsl.rb:6:in `new' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/dsl.rb:6:in `evaluate' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/definition.rb:18:in `build' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler.rb:144:in `definition' /opt/ruby/2.0.0-preview2/lib/ruby/gems/gems/bundler-1.2.3/lib/bundler/cli.rb:228:in `install'

I built ruby and rails from source as a local user and did not have privileges to apt-get libreadline-dev. Reload to refresh your session. AUSの日系企業 ContactSend a Mail FeedyRSS My Feed MainSkip to content Australia Book Business Accounting China CMS Drupal Daily Database Doctrine MongoDB Mysql NoSQL ORM PostgreSQL Design Css Firefox Flash html English weblink alias gem_original_require require private :gem_original_require end ## # When RubyGems is required, Kernel#require is replaced with our own which # is capable of loading gems on demand. # # When you

It also doesn't work on certain platforms (Windows). You signed in with another tab or window. Can I hint the optimizer by giving the range of an integer?

How to fix it?

I'm using knife on an Ubuntu machine, so I'm not sure where the readline package is. However it is easy to fix and after some searching I found a blog post detailing exactly how to solve it. You signed out in another tab or window. Can I use that to take out what he owes me?

Could you lookup what GEM_HOME and GEM_PATH you need for your rbenv Ruby to work? Rebuild ruby with the readline packages (incl. Thanks again sir. check over here OnixGH added the CannotReproduce label Mar 17, 2016 OnixGH closed this Mar 17, 2016 Sign up for free to join this conversation on GitHub.

I was not able to get Passenger 4 to work with RVM, as it insisted upon using site ruby on Mavericks. Any ideas what the issue might be? -- Arthur Kalmenson On Fri, Mar 2, 2012 at 5:38 PM, AJ Christensen wrote: When you built Ruby you didn't have the readline Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 137 Star 3,613 Fork 454 phusion/passenger Code Issues 155 Pull requests 4 Projects Open a shell and type: echo $GEM_HOME echo $GEM_PATH You then need to tell Passenger explicitly to set GEM_HOME and GEM_PATH.

share|improve this answer answered Sep 8 '12 at 21:21 Lasse Dahl Ebert 1,94711722 This answer should be marked as the correct one, @only-bolivan-here. –jackyalcine Sep 24 '12 at 14:28 I haven't really looked at it yet, so I figured now was a good time. I always do: bundle install --path .gems in each of my projects' app roots. Not the answer you're looking for?

I'm using knife on an Ubuntu machine, so I'm not sure where the readline package is. Use `bundle show [gemname]` to see where a bundled gem is installed.
Post-install message from rdoc:
Depending on your version of ruby, you may need to install ruby rdoc/ri If it works, then it's just a workaround, but I'd like to understand why it fails for you in the first place so that I can update Passenger accordingly. Terms Privacy Security Status Help You can't perform that action at this time.

I've installed chef on my workstation with RVM, so perhaps I'm missing the readline header because of that? asked 4 years ago viewed 8858 times active 4 years ago Related 1Readline not compiled by default - Causing `require': no such file to load — readline6“no such file to load Adding rb-readline to Gemfile worked for me. –swornabsent Sep 24 '15 at 20:41 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using I am using RVM and so Ruby exists in ~/.rvm/src/ruby-1.9.2-p180/ for me.

gem 'rb-readline', "~> 0.5.0.pre.1", :require => false share|improve this answer answered Sep 13 '13 at 21:42 Igor Escobar 542310 add a comment| up vote 4 down vote The easiest way to June, 2012 at 1:24 am Great write up! mona is not in the sudoers file. current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.

Wrong way on a bike path? Phusion B.V. Can clients learn their time zone on a network configured using RA?


  • © Copyright 2017 culturahq.com. All rights reserved.